jesseduffield / lazydocker

The lazier way to manage everything docker

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Project selected is incorrect despite running lazydocker from project root

arifb opened this issue · comments

Hi, thanks for the awesome project. I have no containers running. I run docker-compose up -d from a project directory and from the same project directory I run lazydocker.

The project label in lazydocker every so briefly shows the correct project, only to change to another unrelated project which is multiple directories away in the filesystem. And so, all the info in lazydocker is not useful for me, it's showing another (stopped) project.

I'm running Ubuntu via WSL (so on a windows machine).

Sorry for the video but it's the best way to see what's happening.

lazydocker-wrong-project.mp4

I see this also, even when using -f .

additionally it seems lazydocker is stuck - no key/mouse click does anything except q

Hi, folks 👋 I'm seeing a very similar (if not identical) issue. In my case, when launching lazydocker from the same directory as my docker-compose.yml file, the "services" panel of lazydocker usually shows me the "friendly" for each service (read from the docker-compose.yml file. For example, postgres.

Every now and again, for reasons I haven't yet been able to isolate, the "services" panel sometimes ignores the "friendly" name from each service definition in docker-compose.yml and instead falls back to showing the full (ugly) container name, for example, edgepetrol-rest-proxy_postgres_1.

I've also noticed that, when the above "naming issue" arises, some of the power-features, such as pressing "Shift+r" (to view the "restart" options of a selected container), also fail to work.

It's my assumption that, intermittently, the docker-compose.yml fails to be detected in the current working directory, but I can't find a cause or reliable fix. Any help you could offer would be very much appreciated, @jesseduffield, and I'm (of course) happy to share any extra debugging information you require.

Troubleshooting tried so far:

  • Restart lazydocker
  • Restart iTerm2
  • Restart Docker
  • Restart Mac
  • brew uninstall lazydocker && brew install lazydocker

System & Install Info:
MacOS 11.2.2

lazydocker --version
Version: 0.12
Date:
BuildSource: homebrew
Commit:
OS: darwin
Arch: arm64

A quick update, I've just found that the above issue resolved itself after I manually started all of my containers via the docker-compose cli

docker-compose up -d

Now when I open lazydocker, all the containers in the "services" panel display with their "friendly" name, as expected:
Screenshot 2022-02-21 at 17 15 21

I haven't at any point changed my working directory, nor have I made any changes to the docker-compose.yml file.

Perhaps this extra piece of information gives a clue as to where the (intermittent) problem lies?

hmm I haven't ever had this problem myself. I'm afraid I'm quite busy at the moment so can't do a deep dive any time soon but am available to answer any questions

Understood, thanks for the reply, @jesseduffield! I'm a ruby developer and haven't (yet) ventured into the world of go, but perhaps this issue will be my jumping-off point. If I were to try and pick-up a bug fix or two, do you have any issues that feel like a good place to start? Quick-fixes, so to speak.

@dvjones89 nice I'm also a ruby dev in my day job. I'll do an audit of the issue boards (hopefully today) to chuck some good-first-labels on issues which should help

ezoic increase your site revenue