jesseduffield / lazycli

Turn static CLI commands into TUIs with ease

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Unable to install on Ubuntu 18.04

anvandaren opened this issue · comments

Hi,

Just tried to install on Ubuntu 18.04 and it failed with the following error message:

$ cargo install lazycli
    Updating crates.io index
  Downloaded lazycli v0.1.15
  Downloaded 1 crate (22.3 KB) in 1.60s
  Installing lazycli v0.1.15
  Downloaded aho-corasick v0.7.18
  Downloaded cfg-if v1.0.0
  Downloaded atty v0.2.14
  Downloaded bitflags v1.3.2
  Downloaded autocfg v1.0.1
  Downloaded hashbrown v0.11.2
  Downloaded indexmap v1.7.0
  Downloaded linked-hash-map v0.5.4
  Downloaded lazy_static v1.4.0
  Downloaded lock_api v0.4.5
  Downloaded log v0.4.14
  Downloaded clap_derive v3.0.0-beta.5
  Downloaded clap v3.0.0-beta.5
  Downloaded heck v0.3.3
  Downloaded instant v0.1.12
  Downloaded either v1.6.1
  Downloaded dtoa v0.4.8
  Downloaded itertools v0.10.1
  Downloaded directories v3.0.2
  Downloaded crossterm v0.18.2
  Downloaded crossterm v0.19.0
  Downloaded dirs-sys v0.3.6
  Downloaded cassowary v0.3.0
  Downloaded memchr v2.4.1
  Downloaded parking_lot v0.11.2
  Downloaded parking_lot_core v0.8.5
  Downloaded regex v1.5.4
  Downloaded regex-syntax v0.6.25
  Downloaded serde v1.0.130
  Downloaded scopeguard v1.1.0
  Downloaded serde_derive v1.0.130
  Downloaded version_check v0.9.3
  Downloaded unicode-xid v0.2.2
  Downloaded signal-hook-registry v1.4.0
  Downloaded yaml-rust v0.4.5
  Downloaded proc-macro-error-attr v1.0.4
  Downloaded os_str_bytes v4.2.0
  Downloaded mio v0.7.14
  Downloaded quote v1.0.10
  Downloaded strsim v0.10.0
  Downloaded smallvec v1.7.0
  Downloaded proc-macro-error v1.0.4
  Downloaded unicode-width v0.1.9
  Downloaded termcolor v1.1.2
  Downloaded unicode-segmentation v1.8.0
  Downloaded textwrap v0.14.2
  Downloaded proc-macro2 v1.0.32
  Downloaded unicase v2.6.0
  Downloaded serde_yaml v0.8.21
  Downloaded signal-hook v0.1.17
  Downloaded syn v1.0.81
  Downloaded tui v0.14.0
  Downloaded ticker v0.1.1
  Downloaded libc v0.2.105
  Downloaded 54 crates (3.3 MB) in 1.34s
   Compiling libc v0.2.105
   Compiling proc-macro2 v1.0.32
   Compiling unicode-xid v0.2.2
   Compiling version_check v0.9.3
   Compiling syn v1.0.81
   Compiling cfg-if v1.0.0
   Compiling log v0.4.14
   Compiling parking_lot_core v0.8.5
   Compiling memchr v2.4.1
   Compiling serde_derive v1.0.130
   Compiling serde v1.0.130
   Compiling autocfg v1.0.1
   Compiling smallvec v1.7.0
   Compiling scopeguard v1.1.0
   Compiling bitflags v1.3.2
   Compiling lazy_static v1.4.0
   Compiling hashbrown v0.11.2
   Compiling unicode-width v0.1.9
   Compiling unicode-segmentation v1.8.0
   Compiling linked-hash-map v0.5.4
   Compiling dtoa v0.4.8
   Compiling termcolor v1.1.2
   Compiling regex-syntax v0.6.25
   Compiling cassowary v0.3.0
   Compiling strsim v0.10.0
   Compiling either v1.6.1
   Compiling ticker v0.1.1
   Compiling instant v0.1.12
   Compiling proc-macro-error-attr v1.0.4
   Compiling proc-macro-error v1.0.4
   Compiling unicase v2.6.0
   Compiling lock_api v0.4.5
   Compiling textwrap v0.14.2
   Compiling yaml-rust v0.4.5
   Compiling indexmap v1.7.0
   Compiling itertools v0.10.1
   Compiling heck v0.3.3
   Compiling os_str_bytes v4.2.0
   Compiling aho-corasick v0.7.18
   Compiling mio v0.7.14
   Compiling signal-hook-registry v1.4.0
   Compiling atty v0.2.14
   Compiling dirs-sys v0.3.6
   Compiling quote v1.0.10
   Compiling parking_lot v0.11.2
   Compiling signal-hook v0.1.17
   Compiling regex v1.5.4
   Compiling directories v3.0.2
   Compiling crossterm v0.18.2
   Compiling clap_derive v3.0.0-beta.5
   Compiling clap v3.0.0-beta.5
error[E0658]: arbitrary expressions in key-value attributes are unstable
 --> /home/username/.cargo/registry/src/github.com-1ecc6299db9ec823/clap-3.0.0-beta.5/src/lib.rs:8:10
  |
8 | #![doc = include_str!("../README.md")]
  |          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  |
  = note: see issue #78835 <https://github.com/rust-lang/rust/issues/78835> for more information

error[E0658]: use of unstable library feature 'osstring_ascii'
   --> /home/username/.cargo/registry/src/github.com-1ecc6299db9ec823/clap-3.0.0-beta.5/src/parse/matches/matched_arg.rs:130:19
    |
130 |                 v.eq_ignore_ascii_case(val)
    |                   ^^^^^^^^^^^^^^^^^^^^
    |
    = note: see issue #70516 <https://github.com/rust-lang/rust/issues/70516> for more information

error: aborting due to 2 previous errors

For more information about this error, try `rustc --explain E0658`.
error: could not compile `clap`

To learn more, run the command again with --verbose.
warning: build failed, waiting for other jobs to finish...
error: failed to compile `lazycli v0.1.15`, intermediate artifacts can be found at `/tmp/cargo-installVmNGgy`

Caused by:
  build failed

I just installed cargo before this attempt, using apt. That pulled with it the following:
¤ cargo amd64 0.52.0-0ubuntu1~18.04.1
¤ rustc amd64 1.51.0+dfsg1+llvm-1~exp3ubuntu1~18.04.1
¤ libstd-rust-dev amd64 1.51.0+dfsg1+llvm-1~exp3ubuntu1~18.04.1
¤ libstd-rust-1.51 amd64 1.51.0+dfsg1+llvm-1~exp3ubuntu1~18.04.1

Can I do anything to help you debug this?

It looks like that's an older version of Rust, there's a good chance an update will fix it. Try running the following and then try installing lazycli again:

rustup update

Thanks! Had to uninstall cargo and rustc, I had installed via apt. When installing as described on https://rustup.rs/ instead it worked fine. Will close.

ezoic increase your site revenue