jesseduffield / homebrew-lazygit

Homebrew Repo for Lazygit, a UI Terminal for git

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Calling bottle :unneeded is deprecated! There is no replacement.

studious opened this issue · comments

I just thought I would flag this here. It must be a recent brew change. Same for homebrew-lazydocker

Warning: Calling bottle :unneeded is deprecated! There is no replacement.
Please report this issue to the jesseduffield/lazygit tap (not Homebrew/brew or Homebrew/core):
  /usr/local/Homebrew/Library/Taps/jesseduffield/homebrew-lazygit/lazygit.rb:9

Cheers

Seems like it was scheduled to be deprecated in Homebrew 3.3.0 (Homebrew/brew#11622) but has been merged earlier.

As far as I can tell, just removing the bottle: unneeded line fixes the warning, and doesn't cause any issues. Brew doctor also comes up with no errors.

ezoic increase your site revenue