fastlane-community / fastlane-plugin-clean_testflight_testers

Automatically remove TestFlight testers that are not actually testing your app

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Plugin fails to install

st3fan opened this issue Β· comments

Sorry I don't know how to provide more detailed into, but when I try to install this plugin, I get:

sarentz@Risa ~/P/firefox-ios (st3fan/RevisitFastlane) [1]> bundle exec fastlane add_plugin clean_testflight_testers
[βœ”] πŸš€
[16:32:45]: It seems like you wanted to load some plugins, however they couldn't be loaded
[16:32:45]: Please follow the troubleshooting guide: https://docs.fastlane.tools/plugins/plugins-troubleshooting/
[16:32:45]: Plugin 'fastlane-plugin-clean_testflight_testers' was added to './fastlane/Pluginfile'
[16:32:45]: Make sure to commit your Gemfile, Gemfile.lock and Pluginfile to version control
Installing plugin dependencies...
Successfully installed plugins

It says Successfully installed plugins but I don't think that is actually true:

sarentz@Risa ~/P/firefox-ios (st3fan/RevisitFastlane) [1]> bundle exec fastlane update_plugins
[βœ”] πŸš€
[16:33:31]: It seems like you wanted to load some plugins, however they couldn't be loaded
[16:33:31]: Please follow the troubleshooting guide: https://docs.fastlane.tools/plugins/plugins-troubleshooting/
Updating plugin dependencies...

[!] No plugins are installed

Not sure where to go from here.

Oh that's interesting, could you share your ./fastlane/Pluginfile and your ./Gemfile, maybe even your ./Gemfile.lock?

Sorry you're running into this, that shouldn't be an issue, we should be able to resolve it πŸ‘ Thanks

@st3fan Heyyy πŸ‘‹ If you could also run fastlane env and drop that output here as well, I would be happy to take a look into this for you right away

I am not entirely sure what I did different this time, but I upgraded all the things and now the plugin is working for me. We have almost the full 10K testers on this app, it sure is taking a lot of time to fetch those. I hope it does not map to 1 request per user? :-)

I'll close this ticket and report back if I run into problems.