fastlane-community / fastlane-plugin-clean_testflight_testers

Automatically remove TestFlight testers that are not actually testing your app

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Error when passing oldest_build_allowed parameter

chadyj opened this issue · comments

I'm hitting an error when trying to clean testflight users using older builds.

I run bundle exec fastlane pilot builds and see the following builds.

+------------+------------+-----------+
| Version #  | Build #    | Installs  |
+------------+------------+-----------+
| 0.9.13     | 2080.51    | 999      |
| 0.9.12     | 1557.322   | 999      |
+------------+------------+-----------+

In my Fastfile I have:

lane :clean do
  clean_testflight_testers(dry_run: true, oldest_build_allowed: 1557.322)
end

I then run bundle exec fastlane clean

And get the error 'oldest_build_allowed' value must be a Integer! Found String instead.

Issue seems to be coming from https://github.com/KrauseFx/fastlane-plugin-clean_testflight_testers/blob/master/lib/fastlane/plugin/clean_testflight_testers/actions/clean_testflight_testers_action.rb#L37