fastlane-community / fastlane-plugin-appicon

Generate required icon sizes and iconset from a master application icon.

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

0.10 generating blurry app icons

pschneider opened this issue · comments

Hi,

we've used version 0.6 until now and everything worked fine. Today I wanted to update the plugin to the latest version (0.10) to support the :ios_marketing icon. Unfortunately after updating the plugin to the latest version the generated icons are looking very blurry. Re-generating the Icons with 0.6 is fine so I guess our source 1024x1024 image is OK. The Icon sizes seem to be correct for each entry (58x58 etc..).

Running bundle exec fastlane update_plugins appicon changes the following gems:

  • main plugin from 0.6 to 0.10
  • mini_portile2 from 2.2.0 to 2.1.0
  • nokogiri from 1.8.0 to 1.6.8.1

Any clue why it's downgrading these gems and why the generated Icons are blurry for us in the latest version?

Thanks!

Kind regards
Patrick

🚫 fastlane environment 🚫

Stack

Key Value
OS 10.12.6
Ruby 2.4.0
Bundler? true
Git git version 2.13.5 (Apple Git-94)
Installation Source ~/.rvm/gems/ruby-2.4.0/bin/fastlane
Host Mac OS X 10.12.6 (16G29)
Ruby Lib Dir ~/.rvm/rubies/ruby-2.4.0/lib
OpenSSL Version OpenSSL 1.1.0f 25 May 2017
Is contained false
Is homebrew false
Is installed via Fabric.app false
Xcode Path /Applications/Xcode-9.app/Contents/Developer/
Xcode Version 9.0

System Locale

Error
No Locale with UTF8 found 🚫

fastlane files:

(stripped out)

`./fastlane/Fastfile`
# Customise this file, documentation can be found here:
# https://github.com/fastlane/fastlane/tree/master/fastlane/docs
# All available actions: https://docs.fastlane.tools/actions
# can also be listed using the `fastlane actions` command

# Change the syntax highlighting to Ruby
# All lines starting with a # are ignored when running `fastlane`

# If you want to automatically update fastlane if a new version is available:
# update_fastlane

# This is the minimum version number required.
# Update this, if you use features of a newer version
fastlane_version "2.20.0"

skip_docs

default_platform :ios
platform :ios do

  lane :build_icon do
    appicon(appicon_image_file: 'fastlane/metadata/Icon.png',
      appicon_devices: [:ipad, :iphone, :ios_marketing],
      appicon_path: 'Wearparts/Assets.xcassets')
  end

fastlane gems

Gem Version Update-Status
fastlane 2.59.0 Up-To-Date

Loaded fastlane plugins:

Plugin Version Update-Status
fastlane-plugin-appicon 0.10.0 Up-To-Date
Loaded gems
Gem Version
did_you_mean 1.1.0
io-console 0.4.6
CFPropertyList 2.3.5
i18n 0.8.6
minitest 5.10.3
thread_safe 0.3.6
tzinfo 1.2.3
activesupport 4.2.9
public_suffix 2.0.5
addressable 2.5.2
babosa 1.0.2
bundler 1.15.4
claide 1.0.2
clamp 0.6.5
fuzzy_match 2.0.4
nap 1.1.0
cocoapods-core 1.2.1
cocoapods-deintegrate 1.0.1
cocoapods-downloader 1.1.3
cocoapods-plugins 1.0.0
cocoapods-search 1.0.0
cocoapods-stats 1.0.0
netrc 0.7.8
cocoapods-trunk 1.2.0
cocoapods-try 1.1.0
colored2 3.1.2
escape 0.0.4
fourflusher 2.0.1
gh_inspector 1.0.3
molinillo 0.5.7
ruby-macho 1.1.0
nanaimo 0.2.3
xcodeproj 1.5.2
cocoapods 1.2.1
colored 1.2
highline 1.7.8
commander-fastlane 4.4.5
declarative 0.0.10
declarative-option 0.1.0
unf_ext 0.0.7.4
unf 0.1.4
domain_name 0.5.20170404
dotenv 2.2.1
excon 0.59.0
multipart-post 2.0.0
faraday 0.13.1
http-cookie 1.0.3
faraday-cookie_jar 0.0.6
faraday_middleware 0.12.2
fastimage 2.1.0
jwt 1.5.6
little-plugger 1.1.4
multi_json 1.12.2
logging 2.2.2
memoist 0.16.0
os 0.9.6
signet 0.7.3
googleauth 0.5.3
httpclient 2.8.3
mime-types-data 3.2016.0521
mime-types 3.1
uber 0.1.0
representable 3.0.4
retriable 3.1.1
google-api-client 0.13.6
json 2.1.0
mini_magick 4.5.1
multi_xml 0.6.0
plist 3.3.0
rubyzip 1.2.1
security 0.1.3
slack-notifier 1.5.1
terminal-notifier 1.8.0
unicode-display_width 1.3.0
terminal-table 1.8.0
tty-screen 0.5.0
word_wrap 1.0.0
rouge 2.0.7
xcpretty 0.2.8
xcpretty-travis-formatter 0.0.4
fastlane-plugin-appicon 0.10.0
mini_portile2 2.1.0
nokogiri 1.6.8.1
slather 2.4.3

generated on: 2017-09-26

Ugh, sorry to hear that, does it work fine for 0.9.0 and 0.8.0? Could you check that for me please?
Thanks :)

Hi Felix,

It seems that every version above 0.6 does not work. I edited the Pluginfile for each version like so:

gem 'fastlane-plugin-appicon', '0.7.0'

once with 0.7.0, 0.8.0 and 0.9.0

then I ran bundle install which shows that the plugin changes the version correctly. Like:

Using fastlane-plugin-appicon 0.9.0 (was 0.6.0)

other gems are not changed, only the plugin.

After running our lane bundle exec fastlane build_icon I checked the Assets in Xcode which updates accordingly and shows the blurry icons.

Example Screenshot for the iPhone Notification iOS 7-11 20pt preview in the assets catalog:

0.6

appicon_v_060

0.7 - 0.10

appicon_v070

I hope you can see the difference here in this small image :)

@pschneider I've done a big improvement on the way images are generated on 0.7 that may have affected the quality. In our tests at Menvia we could not see any difference but I can use your own icon and example to test it. Can you share the source icon with me?

@felipeplets Sorry for the late reply, some things came up on the weekend.

Unfortunately I can't give you the original icon but it is reproducible with just the tyre. See my attachment. I get the same effect when comparing 0.6 vs >=0.7

icon

Hey @pschneider, thanks for this, could you try completely uninstall and re-installing imagmagick? Also, it might be worth trying a different Mac to see if it has anything to do with the environment

Getting the same issue here. Commenting out image.define("png:exclude-chunks=date,time") in appicon_action.rb fixes it. 🤔

Hi,
we are experiencing the same issue with the latest version (0.13.). Is there an easy workaround? Will this be addressed at some point?

I also noticed this.

Update 1: I've found that when using a .jpg instead of a .png as source image, the icon is perfectly fine.
Update 2: First update got me thinking about the alpha setting, passing remove_alpha: true also fixes it for me! - even with the .png.

Same problem here, very big difference when compared to xcode's own handling:

Screenshot 2020-02-24 at 23 39 35

I've worked a lot with image processing in CMS's and I've never heard of graphicsmagick before, but I've had very good experience with imagemagick (which, btw, is used by badge as well. Could that be something to consider?

I also noticed this.

Update 1: I've found that when using a .jpg instead of a .png as source image, the icon is perfectly fine.
Update 2: First update got me thinking about the alpha setting, passing remove_alpha: true also fixes it for me! - even with the .png.

Experiencing the same, but this doesn't help.