fastlane-community / fastlane-ftp-plugin

Ftp plugin for Fastlane

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Error loading plugin 'fastlane-plugin-ftp'

yu-carter opened this issue · comments

My PluginFile :

Autogenerated by fastlane

Ensure this file is checked in to source control!

gem 'fastlane-plugin-teams_bot'
gem 'fastlane-plugin-firebase_app_distribution'
gem 'fastlane-plugin-ftp'
gem 'fastlane-plugin-gradle_properties'
gem 'fastlane-plugin-android_versioning'

When I run the 'fastlane action ftp' command in the terminal, I get the following error:

[15:56:50]: Error loading plugin 'fastlane-plugin-ftp': cannot load such file -- net/ftp
+-------------------------------------------+---------+------------------------------------------------------------------------+
| Used plugins |
+-------------------------------------------+---------+------------------------------------------------------------------------+
| Plugin | Version | Action |
+-------------------------------------------+---------+------------------------------------------------------------------------+
| fastlane-plugin-teams_bot | 1.0.0 | teams_bot |
| fastlane-plugin-firebase_app_distribution | 0.3.2 | firebase_app_distribution, firebase_app_distribution_add_testers, |
| | | firebase_app_distribution_get_latest_release, |
| | | firebase_app_distribution_get_udids, firebase_app_distribution_login, |
| | | firebase_app_distribution_remove_testers |
| fastlane-plugin-ftp | 0.1.5 | No actions found |
| fastlane-plugin-gradle_properties | 0.1.0 | gradle_properties |
| fastlane-plugin-android_versioning | 0.5.5 | get_value_from_build, get_version_code, get_version_name, |
| | | increment_version_code, increment_version_name, set_value_in_build |
+-------------------------------------------+---------+------------------------------------------------------------------------+

[!] No actions were found while loading one or more plugins
Please use bundle exec fastlane with plugins
More info - https://docs.fastlane.tools/plugins/using-plugins/#run-with-plugins

Loading documentation for ftp:

Couldn't find action for the given filter.

Any update on this? I am running into the same issue.

I had the very same issue, I assume the net/ftp import has been considered optional and removed from Ruby itself.
I found the optional library there https://github.com/ruby/net-ftp
I added it to the Gemfile gem 'net-ftp', installed via bundle install.
The fastlane ftp plugin error seems to be gone.