fastlane-community / danger-xcov

Danger plugin to validate the code coverage of the files changed in a pull request

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

danger-xcov plugin keep complaining about the missing xccoverage file.

singh88 opened this issue · comments

I have tried to use the danger-xcov plugin but I am stuck with this error. This issue is not happening in the main xcov tool https://github.com/fastlane-community/xcov but its happening in the danger plugin.

[18:39:31]: Unable to find any .xccoverage file.
[18:39:31]: Make sure you have enabled 'Gather code coverage' setting on your scheme settings.
[18:39:31]: Alternatively you can provide the full path to your .xccoverage file.

I am using Xcode 13 and I have provided the full path of xcresult which worked with just xcov but not with the danger-xcov


 report = xcov.produce_report(workspace: ENV['XCWORKSPACE'],
      scheme: ENV['SCHEME'],
      minimum_coverage_percentage: 90.00,
      xccov_file_direct_path: ENV['DANGER_XCRESULT_DIRECTORY'], 
      markdown_report: true)

xcov.output_report(report)#

where xcresult path is defined in the .env file export DANGER_XCRESULT_DIRECTORY="fastlane/test_output/$SCHEME.xcresult"

Issues

  • First issue that I see is xcov is not able to pick up the scheme even after I have provided the scheme and workspace details in the parameter.
  • Second it's throwing the error I have pointed out above.

I have the same issue now. It appeared to happen after I defined a dedicated derived data path or updated fastlane maybe? However, not sure how to fix this. Seems to be the same problem mentioned here: fastlane/fastlane#19824