fastlane-community / danger-xcov

Danger plugin to validate the code coverage of the files changed in a pull request

Geek Repo:Geek Repo

Github PK Tool:Github PK Tool

Incompatible with Fastlane 2.137

jake-fooda opened this issue · comments

Inheriting Faraday::Error::ClientError is deprecated; use Faraday::ClientError instead. It will be removed in or after version 1.0
Faraday::Error::ClientError.inherited called from /Users/me/.rvm/gems/ruby-2.3.1/gems/octokit-4.14.0/lib/octokit/middleware/follow_redirects.rb:14.

We're seeing errors running danger-xcov with the latest version of fastlane. Any help with what we're doing wrong would be great. Thanks!

We're using versions:
fastlane 2.137.0
danger 6.1.0
danger-xcov 0.4.1
faraday 0.17.1
octokit 4.14.0
xcov 1.7.0

Will look into tomorrow or Wednesday! Thanks for posting all your gem versions 😊❤️

awesome, thank you!

@joshdholtz Any update on this? Or any other PR that is opened please?

@Kaspik On it now! Won’t leave my desk until merged and released. Thanks for ping ❤️

Thaaank ya!

@joshdholtz Seems like this didn't go as expected... :) Anything we can help with?

@Kaspik My apologies! Needed to get a new version of fastlane out and prepping for a talk/presentation today took longer than expected. Still have the tab open to get to as soon as I can 🙏

@joshdholtz It seems like there is more issues. This uses older xcov, and it's way older so it can't get results from XCode 11 build.

Running on the same code (workspace) xcov (latest) works where running this Danger plugin reports Unable to find any .xccoverage file..

@jake-fooda Are you able to upgrade to Ruby 2.4 at all? Ruby 2.4 has some major security updates to it and a lot of the dependencies that fastlane uses are requiring Ruby 2.4. There are things within the we are trying to do within fastlane to still support older versions of Ruby but its getting harder and harder.

If you could let me know if you could update to Ruby 2.4 and if that works that would be great!

@Kaspik Are you also running something older than Ruby 2.4? 🤔

I’m running 2.7.1 already :)

@joshdholtz I believe my issue is different than this one at the end, and I described that here: #30

We basically need to update this library to latest XCov to support XCode 11 so we don§t have to do in-between steps. :)